Client failing to update revision number of repos


I have a client configured as a testbed, to get data from our development Stratum-1. We have noticed that repositories don’t seem to update. At least the revision number doesn’t match the one on the Stratum-1.

I have tried to remount them with

cvmfs_talk -i <repo> remount

but that didn’t change anything.

I have tried to clean the local cache with

cvmfs_talk -i <repo> cleanup 0

but no luck.

I have tried also pointing directly the squid server inside the Stratum-1 host, instead of the production ones. Same. The revision numbers don’t get updated.

The logs at the client show entries like this:

[root@client~]# grep repo /var/log/messages
Apr 25 16:47:25 client cvmfs2[277181]: (repo) whitelist verification failed (6): invalid whitelist signature

However, the .cvmfswhitelist file looks OK to me. It is identical to the one on the production host.

Any suggestion or tip on what to test? I have ran out of ideas…

The public key on the client was wrong. Fixing it solved the problem.