CVMFS won't mount

when I try to mount cvmfs with

sudo mount -t cvmfs /cvmfs/

I get a message that says CVMFS_HTTP_PROXY required and it won’t allow me to mount it and run the software I need to run

In the first part of this post I was trying to mount it in a VM running CentOS7. I have also tried to mount it in a VM using Ubuntu MATE and running the following:


I get a message that starts with some other stuff and ends up failing at:

HTTP request sent, awaiting response . . . 404 Not Found
2021-11-20 00:11:23 ERROR 404: Not Found

This seems to me like it is also an issue with the HTTP PROXY.


If you are in a new VM, please check that the network is working, then I would suggest following the steps of the Getting Started guide: Getting Started — CernVM-FS 2.9.0 documentation

The setup steps are important, especially creating the default.local file.

Let me know how it goes.

I agree the problem is probably with the default.local file step of the instructions.

I am having trouble creating /etc/cvmfs/default.local and opening the file for editing. How do I do this from the command terminal in CentOS7?

Just use any text editor you have installed, but you have to use sudo. For example:

sudo nano /etc/cvmfs/default.local

I think I have CVMFS installed and mounted properly now. Thanks!

How do I run launch VP1 now that I have it installed and mounted? I have tried running setupATLAS but it says that command does not exist. Does this mean CVMFS is still not set up correctly?

I also do not understand this section in the setup instructions:

Building from source

The CernVM-FS client is not relocatable and needs to be installed under /usr. On Intel architectures, it needs a gcc ≥4.2 compiler, on ARMv7 a gcc ≥4.7 compiler. In order to compile and install from sources, use the following commands

cd mkdir build && cd build cmake …/ make sudo make install

Good to hear!

If you can see the files inside /cvmfs/, it means that CVMFS should be properly set up.

I’m afraid anything experiment specific is beyond my area of expertise, so it’s best to ask someone from ATLAS about how to proceed.

Don’t worry about that section in the documentation. That is relevant when compiling CVMFS from source (not installing it from the rpm packages we provide).