Forcing Client to use IPV4?

in one of our clients we are having issues downloading the repository manifest, and I’m trying to figure out exactly what is going on and whether there is a simple fix to it.

The client is connecting directly to a Stratum-1 server named “cernie1”.

I can “ping cernie1” and “wget http://cernie1” without problems and both use IPV4.

If I try “ping -6 cernie1” I get a “Network is unreachable”.

In the conf file for this domain I set:

but then the logs show me:

jun 06 12:03:09 proton cvmfs2[18029]: ( switching host from http://cernie1/cvmfs/ to http://cernie2/cvmfs/ (failed to resolve host address)
jun 06 12:03:11 proton cvmfs2[18029]: ( failed to download repository manifest (4 - failed to resolve host address)

I thought perhaps adding CVMFS_IPFAMILY_PREFER=4 to the conf file would force CVMS to use only IPV4, but it seems to be doing the same. Any suggestions to fix this?

(if I use an IPV4 IP address directly in the CVMFS_SERVER_URL variable, then all is good, but I’m hoping to avoid that, so that I can switch servers quickly in case of failure, without having to change the clients’ configuration)

does it work with the instance’s FQDN?

What kind of records do you have for the instance in your DNS?

Indeed, with the FQDN it does work just fine.

In all the other clients just “cernie1” was enough and working fine, not sure why, but I guess there is no harm in always setting the FQDN.