Installation issue on MacOS (Apple Silicon)

Hello everyone.
I’m currently installing CernVM-FS on my personal laptop. The versions of CernVM-FS I’m installing are 2.11.0 and 2.11.2.
However, the phrase “The installation failed” keeps popping up every time I try to install it on my computer. The instructions below read “The Installer encountered error that caused the installation to fail. Contact the software manager for assistance.” How do I fix this?
My laptop is mac, and I downloaded and used the pkg file for mac from CernVM File System #download site.

Thank you!

Hi, welcome to the forum!

Did you download the pkg file in Safari? Unfortunately our packages aren’t notarized, so you’ll have to do the download in your terminal, otherwise macOS won’t let you install it. See Getting Started — CernVM-FS 2.11.2 documentation for details. Note also that CVMFS needs macFUSE, which macOS also makes a bit cumbersome to install.
Let me know if that helps.

Hello, thank you for your assistance.
Unfortunately, I downloaded and executed the pkg file for mac using curl in the terminal from the site you already referred to. However, the installation issue is still occurring.
The site you sent me tells me to check if I can use macFuse well by using “kextstat | grep-ifuse” , but if I type in the phrase, I’ll do Executing:
“/usr/bin/kmutil showloaded
No variable specified, falling back to release”,
while the version of macFuse 4.6.0, which I installed, is showing up well in System setting, so maybe something’s wrong here.
If anyone is using macbook air M1 please help.
Have a nice day!

Hmmm, OK, I just checked on an macbook air m1. I had installed cvmfs from source, and the macfuse kext only showed up in the kextstat list once I tried to mount a repository, so that’s not necessarily the problem.

The problem seems to be that that we don’t provide universal binaries on macos yet, and it looks like our postinstall script works fine natively, but fails when run in rosetta.
Do you also see a /tmp/cvmfs_postinstall log file with errors?

The immediate workaround would be for you to build from source, which should be easy (Getting Started — CernVM-FS 2.11.2 documentation). Remember to run cvmfs_config setup once you run sudo make install, and follow the getting started guide from there.

Alternatively I can try to see if I can provide a .pkg built with apple silicon support, it should also not be too complicated, but will take one or two days.

Thank you for your hard work.
Now I’m using a macbook m1 and it’s macOS is Sonoma version 14.3.1.
Unfortunately, when I tried to get the most recent cvmfs pkg file to my computer using a terminal, only “The installation failed. The installer encountered error that caused the installation to fail. Contact the software manager for assistance.”
Thank you for the site you referred to, but I’ve already run that method, and I’m having trouble constantly intalling the pkg file.
The /tmp/cvmfs_postinstall log error you mentioned is not showing up in my terminal. But /tmp/cvmfs_postinstall path exist in my computer.
If you don’t mind, can I get the pkg file based on the apple silicon support you mentioned? my email address is
Have a nice day :slight_smile:


sorry for the late reply. It turns out that unfortunately universal binaries are a bit more complicated to create due to our vendored dependencies - that will have to wait until after some updates to our build infrastructure. But I added a build just for apple silicon now - For M1 macs, try using

curl -o ~/Downloads/cvmfs-2.11.0.pkg

and proceed as usual. Let me know if that works and I’ll copy this .pkg file to our usual download area and update the docs.

OH MY GOD It worked!
Thank you so much for your hard work.
I initialized my computer, installed macfuse version 4.6.0 again, and then I ran the file you gave me, and I installed it and succeeded.
Thank you so much.
Have a wonderful day!!

1 Like